GLSA-201203-20 : Logwatch: Arbitrary code execution

Critical Nessus Plugin ID 59612


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201203-20 (Logwatch: Arbitrary code execution) does not properly sanitize log filenames against shell metacharacters before passing them to the 'system()' function.
Impact :

A remote attacker could pass a specially crafted log filename to Logwatch, possibly resulting in execution of arbitrary code with root privileges or a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All Logwatch users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-apps/logwatch-7.4.0'

See Also

Plugin Details

Severity: Critical

ID: 59612

File Name: gentoo_GLSA-201203-20.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2012/06/21

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:logwatch, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/03/28

Reference Information

CVE: CVE-2011-1018

BID: 46554

OSVDB: 71358

GLSA: 201203-20