Adobe AIR for Mac 3.x <= 3.2.0.2070 Multiple Vulnerabilities (APSB12-14)

High Nessus Plugin ID 59427

Synopsis

The remote Mac OS X host contains a version of Adobe AIR that is
affected by multiple security vulnerabilities.

Description

According to its version, the instance of Adobe AIR on the remote
Mac OS X host is 3.2.0.2070 or earlier and is reportedly affected by
multiple vulnerabilities :

- Multiple memory corruption vulnerabilities exist that
could lead to code execution. (CVE-2012-2034,
CVE-2012-2037)

- A stack overflow vulnerability exists that could lead to
code execution. (CVE-2012-2035)

- An integer overflow vulnerability exists that could lead
to code execution. (CVE-2012-2036)

- A security bypass vulnerability exists that could lead
to information disclosure. (CVE-2012-2038)

- A null dereference vulnerability exists that could lead
to code execution. (CVE-2012-2039)

Solution

Upgrade to Adobe AIR 3.3 (3.3.0.3610) or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb12-14.html

Plugin Details

Severity: High

ID: 59427

File Name: macosx_adobe_air_3_3_0_3610.nasl

Version: 1.11

Type: local

Agent: macosx

Published: 2012/06/09

Modified: 2018/07/14

Dependencies: 56960

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:air

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/08

Vulnerability Publication Date: 2012/06/08

Reference Information

CVE: CVE-2012-2034, CVE-2012-2035, CVE-2012-2036, CVE-2012-2037, CVE-2012-2038, CVE-2012-2039

BID: 53887