Firefox < 10.0.5 Multiple Vulnerabilities (Mac OS X)

High Nessus Plugin ID 59404


The remote Mac OS X host contains a web browser that is affected by multiple vulnerabilities.


The installed version of Firefox is earlier than 10.0.5 and thus, is potentially affected by the following security issues :

- An error exists in the ASN.1 decoder when handling zero length items that can lead to application crashes.

- Multiple memory corruption errors exist. (CVE-2012-1937, CVE-2012-1939)

- Two heap-based buffer overflows and one heap-based use- after-free error exist and are potentially exploitable.
(CVE-2012-1940, CVE-2012-1941, CVE-2012-1947)

- The inline-script blocking feature of the 'Content Security Policy' (CSP) does not properly block inline event handlers. This error allows remote attackers to more easily carry out cross-site scripting attacks.

- A use-after-free error exists related to replacing or inserting a node into a web document. (CVE-2012-1946)


Upgrade to Firefox 10.0.5 ESR or later.

See Also

Plugin Details

Severity: High

ID: 59404

File Name: macosx_firefox_10_0_5.nasl

Version: $Revision: 1.10 $

Type: local

Agent: macosx

Published: 2012/06/07

Modified: 2017/05/16

Dependencies: 55417

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: MacOSX/Firefox/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/06/05

Vulnerability Publication Date: 2012/06/05

Reference Information

CVE: CVE-2012-0441, CVE-2012-1937, CVE-2012-1939, CVE-2012-1940, CVE-2012-1941, CVE-2012-1944, CVE-2012-1946, CVE-2012-1947

BID: 53791, 53792, 53793, 53794, 53797, 53798, 53800, 53801

OSVDB: 82666, 82667, 82669, 82672, 82674, 82675, 82676, 82677