ImageMagick < 6.7.5-8 Multiple Vulnerabilities

High Nessus Plugin ID 59369


The remote Windows host contains an application that is affected by multiple vulnerabilities.


The remote Windows host is running a version of ImageMagick earlier than 6.7.5-8 and is, therefore, affected by the following vulnerabilities :

- The fix for CVE-2012-0247 was incomplete. An integer overflow error still exists and can lead to corrupted memory and arbitrary code execution when user-supplied input is not properly validated. (CVE-2012-1185)

- The fix for CVE-2012-0248 was incomplete. An error in 'profile.c' still allows denial of service attacks when malformed executables are processed. (CVE-2012-1186)


Upgrade to ImageMagick version 6.7.5-8 or later. Alternatively, apply the patches provided by the vendor.

Note that you may need to manually uninstall the vulnerable version from the system.

See Also

Plugin Details

Severity: High

ID: 59369

File Name: imagemagick_6_7_5_8.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Family: Windows

Published: 2012/06/05

Modified: 2017/03/22

Dependencies: 38949

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:imagemagick:imagemagick

Required KB Items: installed_sw/ImageMagick

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/02/29

Vulnerability Publication Date: 2012/03/19

Reference Information

CVE: CVE-2012-1185, CVE-2012-1186

BID: 51957

OSVDB: 80555, 80556