ImageMagick < 6.7.5-1 Multiple Vulnerabilities

High Nessus Plugin ID 59368


The remote Windows host contains an application that is affected by multiple vulnerabilities.


The remote Windows host is running a version of ImageMagick earlier than 6.7.5-1 and is, therefore, affected by the following vulnerabilities :

- An integer overflow error exists related to image IFD and IOP tags. (CVE-2012-0247)

- A parsing error exists related to image IFD and IOP tags that can allow denial of service attacks.


Upgrade to ImageMagick version 6.7.5-1 or later.

Note that you may need to manually uninstall the vulnerable version from the system.

See Also

Plugin Details

Severity: High

ID: 59368

File Name: imagemagick_6_7_5_1.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Family: Windows

Published: 2012/06/05

Modified: 2017/03/22

Dependencies: 38949

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:imagemagick:imagemagick

Required KB Items: installed_sw/ImageMagick

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/02/03

Vulnerability Publication Date: 2012/02/03

Reference Information

CVE: CVE-2012-0247, CVE-2012-0248

BID: 51957

OSVDB: 79003, 79004