Pidgin < 2.10.4 Multiple DoS Vulnerabilities

Medium Nessus Plugin ID 59317


An instant messaging client installed on the remote Windows host is potentially affected by multiple denial of service vulnerabilities.


The version of Pidgin installed on the remote host is earlier than 2.10.4 and is, therefore, potentially affected by the following issues :

- An error exists in the file 'libpurple/proxy.c' that can allow certain file transfer requests to an invalid pointer to be dereferenced, leading to application crashes. (CVE-2012-2214)

- An error exists in the function 'msn_message_parse_payload' in the file 'libpurple/protocols/msn/msg.c' that can allow certain characters or character encodings to crash the application. (CVE-2012-2318)


Upgrade to Pidgin 2.10.4 or later.

See Also

Plugin Details

Severity: Medium

ID: 59317

File Name: pidgin_2_10_4.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2012/05/31

Modified: 2016/05/16

Dependencies: 34205

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:pidgin:pidgin

Required KB Items: SMB/Pidgin/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/05/06

Vulnerability Publication Date: 2012/05/06

Reference Information

CVE: CVE-2012-2214, CVE-2012-2318

BID: 53400, 53706

OSVDB: 81707, 81708