Wireshark 1.6.x < 1.6.8 Multiple Denial of Service Vulnerabilities

Medium Nessus Plugin ID 59240


The remote Windows host contains an application that is affected by multiple denial of service vulnerabilities.


The installed version of Wireshark is 1.6.x before 1.6.8. This version is affected by the following vulnerabilities :

- Input validation errors exist in the dissectors for ANSI MAP, ASF, BACapp, Bluetooth HCI, IEEE 802.11, IEEE 802.3, LTP, and R3 that can allow specially crafted packets to cause the application to enter infinite or very large loops making it unavailable. (Issues 6805, 7118, 7119, 7120, 7121, 7122, 7124, 7125)

- An input validation error exists in the DIAMETER dissector that can allow specially crafted packets to cause improper memory allocation leading to application crashes. (Issue 7138)

- An unspecified error can cause the application to crash due to a memory misalignment. Note, for Windows, this issue only occurs on the Itanium platform. (Issue 7221)


Upgrade to Wireshark version 1.6.8 or later.

See Also





Plugin Details

Severity: Medium

ID: 59240

File Name: wireshark_1_6_8.nasl

Version: $Revision: 1.10 $

Type: local

Agent: windows

Family: Windows

Published: 2012/05/23

Modified: 2016/05/19

Dependencies: 34112

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/05/21

Vulnerability Publication Date: 2012/05/21

Reference Information

CVE: CVE-2012-2392, CVE-2012-2393, CVE-2012-2394, CVE-2012-3825

BID: 53651, 53652, 53653

OSVDB: 82098, 82099, 82100, 82154, 82155, 82156, 82157, 82158, 82159, 82160

EDB-ID: 18918, 18919, 18920