Wireshark 1.4.x < 1.4.13 Multiple Denial of Service Vulnerabilities
Medium Nessus Plugin ID 59239
SynopsisThe remote Windows host contains an application that is affected by multiple denial of service vulnerabilities.
DescriptionThe installed version of Wireshark is 1.4.x before 1.4.13. This version is affected by the following vulnerabilities :
- Input validation errors exist in the dissectors for ANSI MAP, ASF, BACapp, Bluetooth HCI, IEEE 802.11, IEEE 802.3, LTP, and R3 that can allow specially crafted packets to cause the application to enter infinite or very large loops making it unavailable. (Issues 6805, 7118, 7119, 7120, 7121, 7122, 7124, 7125)
- An input validation error exists in the DIAMETER dissector that can allow specially crafted packets to cause improper memory allocation leading to application crashes. (Issue 7138)
- An unspecified error can cause the application to crash due to a memory misalignment. Note, for Windows, this issue only occurs on the Itanium platform. (Issue 7221)
SolutionUpgrade to Wireshark version 1.4.13 or later.