Wireshark 1.4.x < 1.4.13 Multiple Denial of Service Vulnerabilities

low Nessus Plugin ID 59239
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host contains an application that is affected by multiple denial of service vulnerabilities.

Description

The installed version of Wireshark is 1.4.x before 1.4.13. This version is affected by the following vulnerabilities :

- Input validation errors exist in the dissectors for ANSI MAP, ASF, BACapp, Bluetooth HCI, IEEE 802.11, IEEE 802.3, LTP, and R3 that can allow specially crafted packets to cause the application to enter infinite or very large loops making it unavailable. (Issues 6805, 7118, 7119, 7120, 7121, 7122, 7124, 7125)

- An input validation error exists in the DIAMETER dissector that can allow specially crafted packets to cause improper memory allocation leading to application crashes. (Issue 7138)

- An unspecified error can cause the application to crash due to a memory misalignment. Note, for Windows, this issue only occurs on the Itanium platform. (Issue 7221)

Solution

Upgrade to Wireshark version 1.4.13 or later.

See Also

http://www.wireshark.org/security/wnpa-sec-2012-08.html

http://www.wireshark.org/security/wnpa-sec-2012-09.html

http://www.wireshark.org/security/wnpa-sec-2012-10.html

http://www.wireshark.org/docs/relnotes/wireshark-1.4.13.html

Plugin Details

Severity: Low

ID: 59239

File Name: wireshark_1_4_13.nasl

Version: 1.12

Type: local

Agent: windows

Family: Windows

Published: 5/23/2012

Updated: 12/4/2019

Dependencies: wireshark_installed.nasl

Risk Information

CVSS Score Source: CVE-2012-3825

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Low

Base Score: 3.3

Temporal Score: 2.6

Vector: AV:A/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/21/2012

Vulnerability Publication Date: 5/21/2012

Reference Information

CVE: CVE-2012-2392, CVE-2012-2393, CVE-2012-2394, CVE-2012-3825

BID: 53651, 53652, 53653

EDB-ID: 18918, 18919, 18920