Adobe Illustrator CS5 / CS5.5 Multiple Memory Corruption Vulnerabilities (APSB12-10)

High Nessus Plugin ID 59179


The remote Windows host contains an application affected by multiple memory corruption vulnerabilities.


The remote Windows host contains a version of Adobe Illustrator less than CS5 15.0.3 / CS5.5 15.1.1. As such, it reportedly is affected by multiple unspecified memory corruption vulnerabilities that could be exploited to execute arbitrary code.


Either upgrade to Adobe Illustrator CS6 (16.0) or apply the update for CS5 (15.0.3) or CS5.5 (15.1.1).

See Also

Plugin Details

Severity: High

ID: 59179

File Name: adobe_illustrator_apsb12-10.nasl

Version: $Revision: 1.10 $

Type: local

Agent: windows

Family: Windows

Published: 2012/05/17

Modified: 2014/05/18

Dependencies: 43860

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:illustrator

Required KB Items: SMB/Adobe Illustrator/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/05/08

Vulnerability Publication Date: 2012/05/08

Reference Information

CVE: CVE-2012-0780, CVE-2012-2023, CVE-2012-2024, CVE-2012-2025, CVE-2012-2026, CVE-2012-2042

BID: 53422

OSVDB: 81754, 81755, 81756, 81757, 81758, 82404

EDB-ID: 19139