Adobe Flash Professional for Mac <= JPG Object Dimension Memory Allocation FLA File Handling Remote Overflow (APSB12-12)

High Nessus Plugin ID 59178


The remote Mac OS X host has a multimedia authoring application that is affected by a code execution vulnerability.


According to its version, at least one instance of Adobe Flash Professional on the remote Mac OS X host is less than or equal to It is, therefore, reportedly affected by an integer overflow error in Flash.exe when allocating memory to process a JPG object using its image dimensions.


Upgrade to Adobe Flash Professional CS5, Flash Professional CS6, or later.

See Also

Plugin Details

Severity: High

ID: 59178

File Name: macosx_flash_professional_apsb12-12.nasl

Version: $Revision: 1.6 $

Type: local

Agent: macosx

Published: 2012/05/17

Modified: 2012/07/19

Dependencies: 59177

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash, cpe:/a:adobe:flash_cs

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, MacOSX/Adobe Flash Professional/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/05/08

Vulnerability Publication Date: 2012/05/08

Reference Information

CVE: CVE-2012-0778

BID: 53419

OSVDB: 81753

Secunia: 47116