XnView < 1.98.5 Multiple Integer Overflow Vulnerabilities

High Nessus Plugin ID 59174


The remote Windows host contains an application with multiple integer overflow vulnerabilities.


The version of XnView installed on the remote Windows host is earlier than 1.98.5. As such, it is reportedly affected by multiple integer overflow vulnerabilities. These vulnerabilities are related to the processing of PSD (Adobe Photoshop) record types. An attacker could exploit these vulnerabilities by tricking a victim into opening a specially crafted file that could allow for arbitrary code to be executed in the context of the application.


Upgrade to XnView version 1.98.5 or later as that reportedly resolves the issue.

See Also


Plugin Details

Severity: High

ID: 59174

File Name: xnview_1_98_5.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2012/05/17

Modified: 2012/05/18

Dependencies: 30130

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:xnview:xnview

Required KB Items: SMB/XnView/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/01/17

Vulnerability Publication Date: 2012/01/17

Reference Information

CVE: CVE-2012-0684, CVE-2012-0685

BID: 51546

OSVDB: 78356, 78357

MSVR: MSVR12-001