Opera < 11.64 URL Parsing Memory Corruption

High Nessus Plugin ID 59089


The remote host contains a web browser that is potentially affected by a memory corruption vulnerability.


The version of Opera installed on the remote Windows host is earlier than 11.64 and is, therefore, potentially affected by a memory corruption vulnerability.

Certain crafted URLs can cause the application to allocate incorrect amounts of memory and overwrite unrelated memory. This corruption can then lead to application crashes or even arbitrary code execution.


Upgrade to Opera 11.64 or later.

See Also



Plugin Details

Severity: High

ID: 59089

File Name: opera_1164.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2012/05/14

Modified: 2012/08/06

Dependencies: 21746

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Required KB Items: SMB/Opera/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/05/10

Vulnerability Publication Date: 2012/05/10

Reference Information

CVE: CVE-2012-3561

BID: 53474

OSVDB: 81809