Mandriva Linux Security Advisory : openssl (MDVSA-2012:073)

Medium Nessus Plugin ID 59087


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been found and corrected in openssl :

A flaw in the OpenSSL handling of CBC mode ciphersuites in DTLS can be exploited in a denial of service attack on both clients and servers (CVE-2012-2333).

The updated packages have been patched to correct this issue.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 59087

File Name: mandriva_MDVSA-2012-073.nasl

Version: $Revision: 1.8 $

Type: local

Published: 2012/05/14

Modified: 2015/09/01

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64openssl-devel, p-cpe:/a:mandriva:linux:lib64openssl-engines1.0.0, p-cpe:/a:mandriva:linux:lib64openssl-static-devel, p-cpe:/a:mandriva:linux:lib64openssl0.9.8, p-cpe:/a:mandriva:linux:lib64openssl1.0.0, p-cpe:/a:mandriva:linux:libopenssl-devel, p-cpe:/a:mandriva:linux:libopenssl-engines1.0.0, p-cpe:/a:mandriva:linux:libopenssl-static-devel, p-cpe:/a:mandriva:linux:libopenssl0.9.8, p-cpe:/a:mandriva:linux:libopenssl1.0.0, p-cpe:/a:mandriva:linux:openssl, cpe:/o:mandriva:linux:2010.1, cpe:/o:mandriva:linux:2011

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/05/11

Reference Information

CVE: CVE-2012-2333

BID: 53476

MDVSA: 2012:073