PHP < 5.3.11 Multiple Vulnerabilities

Medium Nessus Plugin ID 58966


The remote web server uses a version of PHP that is affected by multiple vulnerabilities.


According to its banner, the version of PHP installed on the remote host is earlier than 5.3.11, and as such is potentially affected by multiple vulnerabilities :

- During the import of environment variables, temporary changes to the 'magic_quotes_gpc' directive are not handled properly. This can lower the difficulty for SQL injection attacks. (CVE-2012-0831)

- The '$_FILES' variable can be corrupted because the names of uploaded files are not properly validated.

- The 'open_basedir' directive is not properly handled by the functions 'readline_write_history' and 'readline_read_history'.

- The 'header()' function does not detect multi-line headers with a CR. (Bug #60227 / CVE-2011-1398)


Upgrade to PHP version 5.3.11 or later.

See Also

Plugin Details

Severity: Medium

ID: 58966

File Name: php_5_3_11.nasl

Version: 1.15

Type: remote

Family: CGI abuses

Published: 2012/05/02

Updated: 2020/04/27

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2012-0831

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2012/04/26

Vulnerability Publication Date: 2012/02/09

Reference Information

CVE: CVE-2011-1398, CVE-2012-0831, CVE-2012-1172

BID: 51954, 53403, 55297