Google Chrome < 18.0.1025.168 Multiple Vulnerabilities

High Nessus Plugin ID 58954


The remote host contains a web browser that is affected by multiple vulnerabilities.


The version of Google Chrome installed on the remote host is earlier than 18.0.1025.168 and is, therefore, affected by the following vulnerabilities :

- Use-after-free errors exist related to floating element handling and the xml parser. (CVE-2011-3078, CVE-2012-1521, CVE-2011-3081)

- A validation error exists related to Inter-Process Communications (IPC). (CVE-2011-3079)

- A race condition exists in the method 'CrossCallParamsEx::CreateFromBuffer' in the file 'sandbox/src/' and is related to sandbox Inter-Process Communication (IPC).


Upgrade to Google Chrome 18.0.1025.168 or later.

See Also

Plugin Details

Severity: High

ID: 58954

File Name: google_chrome_18_0_1025_168.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Family: Windows

Published: 2012/05/01

Modified: 2016/05/16

Dependencies: 34196

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/04/30

Vulnerability Publication Date: 2012/04/30

Reference Information

CVE: CVE-2011-3078, CVE-2011-3079, CVE-2011-3080, CVE-2011-3081, CVE-2012-1521

BID: 53309

OSVDB: 81643, 81644, 81645, 81646, 81647