Intuit QuickBooks Help System Multiple Vulnerabilities

High Nessus Plugin ID 58848


Business accounting software installed on the remote Windows host has multiple vulnerabilities.


The version of QuickBooks installed on the remote host has multiple vulnerabilities. Versions 2008 through 2012 have multiple vulnerabilities in the help system that could result in information disclosure or memory corruption.

A remote attacker could exploit these issues by tricking a user into requesting a maliciously crafted web page, resulting in arbitrary code execution.


Fixes are available for QuickBooks 2008 through 2012 via the automatic update mechanism. The presence of the patch can be verified by checking if the digital signature of HelpAsyncPluggableProtocol.dll has a signing date of April 27, 2012 or later.

If updating is not possible, workarounds that disable QuickBooks help pages are available. Refer to the researcher's advisory for more information. Note that deleting or renaming the affected DLL may not be adequate under some circumstances.

See Also

Plugin Details

Severity: High

ID: 58848

File Name: quickbooks_help_multiple.nasl

Version: $Revision: 1.8 $

Type: local

Agent: windows

Family: Windows

Published: 2012/04/24

Modified: 2013/06/04

Dependencies: 58847

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:U/RC:ND

Vulnerability Information

CPE: cpe:/a:intuit:quickbooks

Required KB Items: SMB/QuickBooks/Installed, SMB/ARCH

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/05/21

Vulnerability Publication Date: 2012/03/30

Reference Information

CVE: CVE-2012-2418, CVE-2012-2419, CVE-2012-2420, CVE-2012-2421, CVE-2012-2422, CVE-2012-2423, CVE-2012-2424, CVE-2012-2425

BID: 52836, 52854

OSVDB: 80819, 80820, 81807, 81833, 81834, 81835, 81836, 81840

CERT: 232979

Secunia: 48686