Mandriva Linux Security Advisory : raptor (MDVSA-2012:061)

Medium Nessus Plugin ID 58830


The remote Mandriva Linux host is missing one or more security updates.


An XML External Entity expansion flaw was found in the way Raptor processed RDF files. If an application linked against Raptor were to open a specially crafted RDF file, it could possibly allow a remote attacker to obtain a copy of an arbitrary local file that the user running the application had access to. A bug in the way Raptor handled external entities could cause that application to crash or, possibly, execute arbitrary code with the privileges of the user running the application (CVE-2012-0037).

The updated packages have been patched to correct this issue.

raptor2 for Mandriva Linux 2011 has been upgraded to the 2.0.7 version which is not vulnerable to this issue.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 58830

File Name: mandriva_MDVSA-2012-061.nasl

Version: $Revision: 1.7 $

Type: local

Published: 2012/04/23

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64raptor-devel, p-cpe:/a:mandriva:linux:lib64raptor1, p-cpe:/a:mandriva:linux:lib64raptor2-devel, p-cpe:/a:mandriva:linux:lib64raptor2_0, p-cpe:/a:mandriva:linux:libraptor-devel, p-cpe:/a:mandriva:linux:libraptor1, p-cpe:/a:mandriva:linux:libraptor2-devel, p-cpe:/a:mandriva:linux:libraptor2_0, p-cpe:/a:mandriva:linux:raptor, p-cpe:/a:mandriva:linux:raptor2, cpe:/o:mandriva:linux:2010.1, cpe:/o:mandriva:linux:2011

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2012/04/21

Reference Information

CVE: CVE-2012-0037

MDVSA: 2012:061