OpenSSL < 0.9.8w ASN.1 asn1_d2i_read_bio Memory Corruption

High Nessus Plugin ID 58799


The remote host may be affected by a memory corruption vulnerability.


According to its banner, the remote web server is running a version of OpenSSL earlier than 0.9.8w. As such, the OpenSSL library itself is reportedly affected by a memory corruption vulnerability via an integer truncation error in the function 'asn1_d2i_read_bio' when reading ASN.1 DER format data.

Applications using the 'BIO' or 'FILE' based functions (i.e., 'd2i_*_bio' or 'd2i_*_fp' functions) are affected by this issue.
Also affected are 'S/MIME' or 'CMS' applications using 'SMIME_read_PKCS7' or 'SMIME_read_CMS' parsers. The OpenSSL command line utility is affected if used to handle untrusted DER formatted data.

Note that the SSL/TLS code of OpenSSL is not affected. Also not affected are applications using memory-based ASN.1 functions (e.g., 'd2i_X509', 'd2i_PKCS12', etc.) nor are applications using only PEM functions.

Note also that the original fix for CVE-2012-2110 in 0.9.8v was incomplete because the functions 'BUF_MEM_grow' and 'BUF_MEM_grow_clean', in file 'openssl/crypto/buffer/buffer.c', did not properly account for negative values of the argument 'len'.


Upgrade to OpenSSL 0.9.8w or later.

See Also

Plugin Details

Severity: High

ID: 58799

File Name: openssl_0_9_8v.nasl

Version: $Revision: 1.15 $

Type: remote

Family: Web Servers

Published: 2012/04/24

Modified: 2017/06/12

Dependencies: 57323

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/04/19

Vulnerability Publication Date: 2012/04/19

Reference Information

CVE: CVE-2012-2110, CVE-2012-2131

BID: 53158, 53212

OSVDB: 81223, 82110

EDB-ID: 18756