Netop Remote Control dws File Handling Overflow

High Nessus Plugin ID 58769


There is an application installed on the remote host that is affected by a buffer overflow vulnerability.


Netop Remote Control Guest is installed on the remote Windows host and is less than version 10.0 build 2011087. As such, it reportedly has a flaw in handling '.dws' script files that can be utilized to trigger a buffer overflow.

By tricking the user into opening a specially crafted '.dws' file, a remote attacker may be able to execute arbitrary code subject to the user's privileges.


Upgrade to Netop Remote Control Guest 10.0 build 2011087 or greater.

See Also

Plugin Details

Severity: High

ID: 58769

File Name: netop_remote_control_guest_dws_bof.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2012/04/17

Modified: 2017/02/07

Dependencies: 58770

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

Vulnerability Information

CPE: cpe:/a:netop:remote_control

Required KB Items: SMB/Netop_Remote_Control_Guest/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/03/30

Vulnerability Publication Date: 2011/04/28

Exploitable With

Metasploit (NetOp Remote Control Client 9.5 Buffer Overflow)

Reference Information

BID: 47631

OSVDB: 72291

EDB-ID: 17223, 18697