Debian DSA-2449-1 : sqlalchemy - missing input sanitization

High Nessus Plugin ID 58728

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that SQLAlchemy, a SQL toolkit and object relational mapper for Python, is not sanitizing input passed to the limit/offset keywords to select() as well as the value passed to select.limit()/offset(). This allows an attacker to perform SQL injection attacks against applications using SQLAlchemy that do not implement their own filtering.

Solution

Upgrade the sqlalchemy packages.

For the stable distribution (squeeze), this problem has been fixed in version 0.6.3-3+squeeze1.

See Also

https://packages.debian.org/source/squeeze/sqlalchemy

https://www.debian.org/security/2012/dsa-2449

Plugin Details

Severity: High

ID: 58728

File Name: debian_DSA-2449.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2012/04/13

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:sqlalchemy, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/04/12

Reference Information

CVE: CVE-2012-0805

BID: 52330

DSA: 2449