MS12-028: Vulnerability in Microsoft Office Could Allow Remote Code Execution (2639185)

High Nessus Plugin ID 58660

Synopsis

The remote Windows host could allow arbitrary code execution.

Description

The remote host is running a version of Microsoft Works for Windows document converter that is affected by a heap overflow vulnerability.
If an attacker can trick a user on the affected host into opening a specially crafted Works file, this issue could be leveraged to run arbitrary code on the host subject to the user's privileges.

Solution

Microsoft has released a set of patches for Microsoft Office 2007, Microsoft Works 9, and Microsoft Works 6-9 File Converter.

See Also

https://technet.microsoft.com/library/security/ms12-028

Plugin Details

Severity: High

ID: 58660

File Name: smb_nt_ms12-028.nasl

Version: 1.22

Type: local

Agent: windows

Published: 2012/04/11

Modified: 2018/08/03

Dependencies: 27524, 57033, 13855

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows, cpe:/a:microsoft:office, cpe:/a:microsoft:works, cpe:/a:microsoft:works_6-9_file_converter

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/04/10

Vulnerability Publication Date: 2012/04/10

Reference Information

CVE: CVE-2012-0177

BID: 52867

MSFT: MS12-028

IAVB: 2012-B-0041

MSKB: 2596871, 2680317, 2680326