Cisco WebEx WRF Player Multiple Buffer Overflows (cisco-sa-20120404-webex)

high Nessus Plugin ID 58621
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The video player installed on the remote Windows host has multiple buffer overflow vulnerabilities.

Description

The version of Cisco WebEx WRF Player installed on the remote host has multiple buffer overflow vulnerabilities. An attacker could exploit these issues by tricking a user into opening a malicious WRF file, resulting in arbitrary code execution.

Solution

Upgrade to the latest version of the WebEx WRF Player as described in Cisco advisory cisco-sa-20120404-webex.

See Also

http://www.nessus.org/u?e6ad1fb0

Plugin Details

Severity: High

ID: 58621

File Name: cisco-sa-20120404-webex.nasl

Version: 1.7

Type: local

Agent: windows

Family: Windows

Published: 4/6/2012

Updated: 11/15/2018

Dependencies: webex_player_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:cisco:webex_recording_format_player

Required KB Items: SMB/WRF Player/path

Exploit Ease: No known exploits are available

Patch Publication Date: 4/4/2012

Vulnerability Publication Date: 4/4/2012

Reference Information

CVE: CVE-2012-1335, CVE-2012-1336, CVE-2012-1337

BID: 52882