Mandriva Linux Security Advisory : gnutls (MDVSA-2012:045)

Medium Nessus Plugin ID 58557


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been found and corrected in GnuTLS :

Buffer overflow in the gnutls_session_get_data function in lib/gnutls_session.c in GnuTLS 2.12.x before 2.12.14 and 3.x before 3.0.7, when used on a client that performs nonstandard session resumption, allows remote TLS servers to cause a denial of service (application crash) via a large SessionTicket (CVE-2011-4128).

The updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 58557

File Name: mandriva_MDVSA-2012-045.nasl

Version: $Revision: 1.6 $

Type: local

Published: 2012/04/02

Modified: 2013/10/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gnutls, p-cpe:/a:mandriva:linux:lib64gnutls-devel, p-cpe:/a:mandriva:linux:lib64gnutls-ssl27, p-cpe:/a:mandriva:linux:lib64gnutls26, p-cpe:/a:mandriva:linux:libgnutls-devel, p-cpe:/a:mandriva:linux:libgnutls-ssl27, p-cpe:/a:mandriva:linux:libgnutls26, cpe:/o:mandriva:linux:2010.1, cpe:/o:mandriva:linux:2011

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/03/30

Reference Information

CVE: CVE-2011-4128

BID: 50609

MDVSA: 2012:045