Wireshark 1.4.x < 1.4.12 Multiple Denial of Service Vulnerabilities

Medium Nessus Plugin ID 58517


The remote Windows host contains an application that is affected by multiple denial of service vulnerabilities.


The installed version of Wireshark is 1.4.x before 1.4.12. This version is affected by the following vulnerabilities :

- An error exists in the pcap and pcap-ng parsers that can allow them to crash when reading 'ERF' data.
(Issue 6804)

- An error exists in the 'ANSI A' dissector that can allow it to crash after dereferencing a NULL pointer.
(Issue 6823)

- An error exists in the 'MP2T' dissector that can allow it to allocate too much memory thus, resulting in crashes. (Issue 6833)


Upgrade to Wireshark version 1.4.12 or later.

See Also





Plugin Details

Severity: Medium

ID: 58517

File Name: wireshark_1_4_12.nasl

Version: $Revision: 1.9 $

Type: local

Agent: windows

Family: Windows

Published: 2012/03/28

Modified: 2016/05/19

Dependencies: 34112

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/03/27

Vulnerability Publication Date: 2012/03/27

Reference Information

CVE: CVE-2012-1593, CVE-2012-1594, CVE-2012-1595, CVE-2012-1596

BID: 52735, 52736, 52737, 52738

OSVDB: 80711, 80712, 80713, 80714

EDB-ID: 18758