Mandriva Linux Security Advisory : file (MDVSA-2012:035)

Medium Nessus Plugin ID 58474

Synopsis

The remote Mandriva Linux host is missing one or more security updates.

Description

Multiple out-of heap-based buffer read flaws and invalid pointer dereference flaws were found in the way file, utility for determining of file types processed header section for certain Composite Document Format (CDF) files. A remote attacker could provide a specially crafted CDF file, which once inspected by the file utility of the victim would lead to file executable crash (CVE-2012-1571).

The updated packages for Mandriva Linux 2011 have been upgraded to the 5.11 version and the packages for Mandriva Linux 2010.2 has been patched to correct these issues.

Solution

Update the affected packages.

See Also

https://bugzilla.redhat.com/show_bug.cgi?id=805197

Plugin Details

Severity: Medium

ID: 58474

File Name: mandriva_MDVSA-2012-035.nasl

Version: 1.11

Type: local

Published: 2012/03/26

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:file, p-cpe:/a:mandriva:linux:lib64magic-devel, p-cpe:/a:mandriva:linux:lib64magic-static-devel, p-cpe:/a:mandriva:linux:lib64magic1, p-cpe:/a:mandriva:linux:libmagic-devel, p-cpe:/a:mandriva:linux:libmagic-static-devel, p-cpe:/a:mandriva:linux:libmagic1, p-cpe:/a:mandriva:linux:python-magic, cpe:/o:mandriva:linux:2010.1, cpe:/o:mandriva:linux:2011

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/03/23

Reference Information

CVE: CVE-2012-1571

BID: 52225

MDVSA: 2012:035