nginx < 1.0.14 / 1.1.17 HTTP Header Response Memory Disclosure

Medium Nessus Plugin ID 58414


The web server on the remote host is affected by a memory disclosure vulnerability.


The remote web server is running nginx, a lightweight, high performance web server / reverse proxy and email (IMAP/POP3) proxy.

According to its Server response header, the installed version of nginx is earlier than 1.0.14 or is 1.1.x before 1.1.17 and is, therefore, affected by a memory disclosure vulnerability.

An issue related to the parsing of HTTP header responses can allow a remote attacker to obtain the contents of previously freed memory.


Upgrade to version 1.0.14 / 1.1.17 or later.

See Also

Plugin Details

Severity: Medium

ID: 58414

File Name: nginx_1_0_14.nasl

Version: $Revision: 1.8 $

Type: remote

Family: Web Servers

Published: 2012/03/21

Modified: 2018/01/29

Dependencies: 106375

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/03/15

Vulnerability Publication Date: 2012/03/15

Reference Information

CVE: CVE-2012-1180

BID: 52578

OSVDB: 80124