nginx < 1.0.10 ngx_resolver_copy Function DNS Response Parsing Buffer Overflow

Medium Nessus Plugin ID 58413


The web server on the remote host is affected by a buffer overflow vulnerability.


The remote web server is running nginx, a lightweight, high performance web server / reverse proxy and email (IMAP/POP3) proxy.

According to its Server response header, the installed version of nginx is earlier than 1.0.10 and is, therefore, affected by a heap-based buffer overflow vulnerability.

An issue related to DNS response parsing exists in the function 'ngx_resolver_copy' in the file 'ngx_resolver.c' which can allow remote attackers to cause a denial of service or possibly execute arbitrary code.

Note that successful exploitation requires this application's custom DNS resolver to be enabled and that this custom resolver is not enabled by default.


Upgrade to version 1.0.10 or later.

See Also

Plugin Details

Severity: Medium

ID: 58413

File Name: nginx_1_0_10.nasl

Version: $Revision: 1.6 $

Type: remote

Family: Web Servers

Published: 2012/03/21

Modified: 2018/01/26

Dependencies: 106375

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 5.6

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/11/15

Vulnerability Publication Date: 2011/11/15

Reference Information

CVE: CVE-2011-4315

BID: 50710

OSVDB: 77184