Debian DSA-2434-1 : nginx - sensitive information leak

medium Nessus Plugin ID 58391

Synopsis

The remote Debian host is missing a security-related update.

Description

Matthew Daley discovered a memory disclosure vulnerability in nginx.
In previous versions of this web server, an attacker can receive the content of previously freed memory if an upstream server returned a specially crafted HTTP response, potentially exposing sensitive information.

Solution

Upgrade the nginx packages.

For the stable distribution (squeeze), this problem has been fixed in version 0.7.67-3+squeeze2.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=664137

https://packages.debian.org/source/squeeze/nginx

https://www.debian.org/security/2012/dsa-2434

Plugin Details

Severity: Medium

ID: 58391

File Name: debian_DSA-2434.nasl

Version: 1.9

Type: local

Agent: unix

Published: 3/20/2012

Updated: 1/11/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 1.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:nginx, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 3/19/2012

Reference Information

CVE: CVE-2012-1180

DSA: 2434