Fedora 17 : python-mwlib-0.13.5-1.fc17 (2012-3138)

High Nessus Plugin ID 58310


The remote Fedora host is missing a security update.


Update to version 0.13.5, which solves the following issues :

It was reported that mwlib suffered from a flaw that could allow a remote attacker to perform a denial of service attack on a mwlib installation by forcing it to parse a specially crafted #iferror magic function. This issue has been resolved in version 0.13.5.

syntaxhighlight nodes are supported properly in version 0.13.5.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected python-mwlib package.

See Also




Plugin Details

Severity: High

ID: 58310

File Name: fedora_2012-3138.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2012/03/12

Modified: 2015/10/20

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:python-mwlib, cpe:/o:fedoraproject:fedora:17

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2012/03/07

Reference Information

FEDORA: 2012-3138