GLSA-201203-07 : foomatic-filters: User-assisted execution of arbitrary code

Medium Nessus Plugin ID 58217


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201203-07 (foomatic-filters: User-assisted execution of arbitrary code)

The foomatic-rip filter improperly handles command-line arguments, including those issued by FoomaticRIPCommandLine fields in PPD files.
Impact :

A remote attacker could entice a user to open a specially crafted PPD file, possibly resulting in execution of arbitrary code with the privileges of the system user 'lp'.
Workaround :

There is no known workaround at this time.


All foomatic-filters users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-print/foomatic-filters-4.0.9'

See Also

Plugin Details

Severity: Medium

ID: 58217

File Name: gentoo_GLSA-201203-07.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2012/03/06

Modified: 2016/05/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:foomatic-filters, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/03/06

Reference Information

CVE: CVE-2011-2697, CVE-2011-2964

BID: 48674

GLSA: 201203-07