GLSA-201203-05 : Rack: Denial of Service

Medium Nessus Plugin ID 58215

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201203-05 (Rack: Denial of Service)

Rack does not properly randomize hash functions to protect against hash collision attacks.
Impact :

A remote attacker could send a specially crafted form post, possibly resulting in a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All Rack users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-ruby/rack-1.1.3'

See Also

https://security.gentoo.org/glsa/201203-05

Plugin Details

Severity: Medium

ID: 58215

File Name: gentoo_GLSA-201203-05.nasl

Version: 1.7

Type: local

Published: 2012/03/06

Updated: 2020/09/24

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:rack, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/03/06

Reference Information

CVE: CVE-2011-5036

BID: 51197

GLSA: 201203-05