GLSA-201203-03 : Puppet: Multiple vulnerabilities

Medium Nessus Plugin ID 58213


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201203-03 (Puppet: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Puppet. Please review the CVE identifiers referenced below for details.
Impact :

A local attacker could gain elevated privileges, or access and modify arbitrary files. Furthermore, a remote attacker may be able to spoof a Puppet Master or write X.509 Certificate Signing Requests to arbitrary locations.
Workaround :

There is no known workaround at this time.


All Puppet users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-admin/puppet-2.7.11'

See Also

Plugin Details

Severity: Medium

ID: 58213

File Name: gentoo_GLSA-201203-03.nasl

Version: $Revision: 1.8 $

Type: local

Published: 2012/03/06

Modified: 2016/11/11

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Temporal Score: 6

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:puppet, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/03/06

Reference Information

CVE: CVE-2009-3564, CVE-2010-0156, CVE-2011-3848, CVE-2011-3869, CVE-2011-3870, CVE-2011-3871, CVE-2011-3872, CVE-2012-1053, CVE-2012-1054

BID: 36628, 38474, 49860, 49909, 50356, 52158

OSVDB: 58657, 75986, 75988, 75989, 76018, 76623, 79495, 79496

GLSA: 201203-03

CWE: 59, 264