GLSA-201203-01 : spamdyke: Arbitrary code execution

High Nessus Plugin ID 58211


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201203-01 (spamdyke: Arbitrary code execution)

Boundary errors related to the 'snprintf()' and 'vsnprintf()' functions in spamdyke could cause a buffer overflow.
Impact :

A remote attacker could possibly execute arbitrary code or cause a Denial of Service.
Workaround :

There is no known workaround at this time.


All spamdyke users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=mail-filter/spamdyke-4.3.0'

See Also

Plugin Details

Severity: High

ID: 58211

File Name: gentoo_GLSA-201203-01.nasl

Version: $Revision: 1.6 $

Type: local

Published: 2012/03/06

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:spamdyke, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/03/06

Reference Information

CVE: CVE-2012-0802

BID: 51440

OSVDB: 78351

GLSA: 201203-01