Fedora 16 : glibc-2.14.90-24.fc16.6 (2012-2162)

Medium Nessus Plugin ID 58124


The remote Fedora host is missing a security update.


Avoid 'nargs' integer overflow which can be used to bypass FORTIFY_SOURCE protections.

Revert changes for 552960, they're still causing problems.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected glibc package.

See Also



Plugin Details

Severity: Medium

ID: 58124

File Name: fedora_2012-2162.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2012/02/27

Modified: 2015/10/20

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:glibc, cpe:/o:fedoraproject:fedora:16

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2012/02/22

Reference Information

CVE: CVE-2012-0864

FEDORA: 2012-2162