Mandriva Linux Security Advisory : libvpx (MDVSA-2012:023-1)

Medium Nessus Plugin ID 58103


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been found and corrected in libvpx :

VP8 Codec SDK (libvpx) before 1.0.0 Duclair allows remote attackers to cause a denial of service (application crash) via (1) unspecified corrupt input or (2) by starting decoding from a P-frame, which triggers an out-of-bounds read, related to the clamping of motion vectors in SPLITMV blocks (CVE-2012-0823).

The updated packages have been patched to correct this issue.

Update :

This is a symbolic advisory correction because there was a clash with MDVSA-2012:023 that addressed libxml2.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 58103

File Name: mandriva_MDVSA-2012-023.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2012/02/23

Modified: 2016/03/11

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64vpx-devel, p-cpe:/a:mandriva:linux:lib64vpx0, p-cpe:/a:mandriva:linux:libvpx-devel, p-cpe:/a:mandriva:linux:libvpx-utils, p-cpe:/a:mandriva:linux:libvpx0, cpe:/o:mandriva:linux:2010.1, cpe:/o:mandriva:linux:2011

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/02/28

Reference Information

CVE: CVE-2012-0823

BID: 51775, 52107

OSVDB: 79604

MDVSA: 2012:023-1