GLSA-201202-06 : Asterisk: Denial of Service

Medium Nessus Plugin ID 58102


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201202-06 (Asterisk: Denial of Service)

A vulnerability has been found in Asterisk's handling of certain encrypted streams where the res_srtp module has been loaded but video support has not been enabled.
Impact :

A remote attacker could send a specially crafted SDP message to the Asterisk daemon, possibly resulting in a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All Asterisk users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/asterisk-'

See Also

Plugin Details

Severity: Medium

ID: 58102

File Name: gentoo_GLSA-201202-06.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2012/02/23

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:asterisk, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/02/22

Reference Information

CVE: CVE-2012-0885

BID: 51581

OSVDB: 78482

GLSA: 201202-06