Debian DSA-2417-1 : libxml2 - computational denial of service

medium Nessus Plugin ID 58097

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that the internal hashing routine of libxml2, a library providing an extensive API to handle XML data, is vulnerable to predictable hash collisions. Given an attacker with knowledge of the hashing algorithm, it is possible to craft input that creates a large amount of collisions. As a result it is possible to perform denial of service attacks against applications using libxml2 functionality because of the computational overhead.

Solution

Upgrade the libxml2 packages.

For the stable distribution (squeeze), this problem has been fixed in version 2.7.8.dfsg-2+squeeze3.

See Also

https://packages.debian.org/source/squeeze/libxml2

https://www.debian.org/security/2012/dsa-2417

Plugin Details

Severity: Medium

ID: 58097

File Name: debian_DSA-2417.nasl

Version: 1.18

Type: local

Agent: unix

Published: 2/23/2012

Updated: 1/11/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 2.7

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libxml2, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2/22/2012

Reference Information

CVE: CVE-2012-0841

BID: 52107

DSA: 2417