RHEL 4 : firefox (RHSA-2012:0142)

High Nessus Plugin ID 57994


The remote Red Hat host is missing a security update.


An updated firefox package that fixes one security issue is now available for Red Hat Enterprise Linux 4.

The Red Hat Security Response Team has rated this update as having critical security impact. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available from the CVE link in the References section.

Mozilla Firefox is an open source web browser.

A heap-based buffer overflow flaw was found in the way Firefox handled PNG (Portable Network Graphics) images. A web page containing a malicious PNG image could cause Firefox to crash or, possibly, execute arbitrary code with the privileges of the user running Firefox.

All Firefox users should upgrade to this updated package, which corrects this issue. After installing the update, Firefox must be restarted for the changes to take effect.


Update the affected firefox package.

See Also



Plugin Details

Severity: High

ID: 57994

File Name: redhat-RHSA-2012-0142.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2012/02/17

Modified: 2017/01/05

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:firefox, cpe:/o:redhat:enterprise_linux:4

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2012/02/16

Reference Information

CVE: CVE-2011-3026

OSVDB: 79294

RHSA: 2012:0142