MS12-008: Vulnerabilities in Windows Kernel-Mode Drivers Could Allow Remote Code Execution (2660465)

High Nessus Plugin ID 57942


The remote Windows kernel is affected by multiple remote code execution vulnerabilities.


The remote host is running a version of the Windows kernel that is affected by multiple remote code execution vulnerabilities :

- Due to improper validation in input passed from user mode through the kernel component of GDI, an attacker can cause a denial of service condition or may be able to execute arbitrary code in kernel mode.

- A flaw in the way the Windows kernel-mode drivers manages specific keyboard layouts could allow an attacker to run arbitrary code in kernel mode.


Microsoft has released a set of patches for Windows XP, 2003, Vista, 2008, 7, and 2008 R2.

See Also

Plugin Details

Severity: High

ID: 57942

File Name: smb_nt_ms12-008.nasl

Version: $Revision: 1.14 $

Type: local

Agent: windows

Published: 2012/02/14

Modified: 2017/11/06

Dependencies: 57033, 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:U/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/02/14

Vulnerability Publication Date: 2011/12/18

Reference Information

CVE: CVE-2011-5046, CVE-2012-0154

BID: 51122, 51920

OSVDB: 77908, 79269

EDB-ID: 18275

MSFT: MS12-008

MSKB: 2660465