LuraWave JP2 Browser Plug-In < 2.1.1.11 npjp2.dll Remote Buffer Overflow

high Nessus Plugin ID 57940
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host has a browser plug-in that is affected by a buffer overflow vulnerability.

Description

The version of the LuraWave JP2 Browser Plug-In installed on the remote Windows host is earlier than 2.1.1.11 and thus reportedly contains a stack-based buffer overflow vulnerability.

If an attacker can trick a user on the affected host into viewing a specially crafted HTML document, he can leverage this issue to execute arbitrary code on the affected system subject to the user's privileges.

Solution

Upgrade to version 2.1.1.11 or later.

Plugin Details

Severity: High

ID: 57940

File Name: lurawave_jp2_browser_plugin_overflow.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 2/14/2012

Updated: 7/14/2018

Dependencies: smb_hotfixes.nasl, opera_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:luratech:lurawave_jp2_browser_plug-in

Required KB Items: SMB/Registry/Enumerated

Exploit Ease: No known exploits are available

Patch Publication Date: 1/31/2012

Vulnerability Publication Date: 1/31/2012

Reference Information

CVE: CVE-2012-0978

BID: 51732

Secunia: 47831