Novell iPrint Client < 5.78 Multiple Code Execution Vulnerabilities

High Nessus Plugin ID 57890


The remote host contains an application that is affected by multiple code execution vulnerabilities.


The version of Novell iPrint Client installed on the remote host is earlier than 5.78. Such versions are reportedly affected by one or more of the following vulnerabilities that can allow for arbitrary code execution :

- An unspecified issue exists in the GetDriverSettings realm in nipplib.dll. (CVE-2011-4187)

- An unspecified issue exists in GetPrinterURLList2 in the ActiveX control. (CVE-2011-4185)

- An unspecified issue exists in client-file-name parsing in nipplib.dll. (CVE-2011-4186)


Upgrade to Novell iPrint Client 5.78 or later.

See Also

Plugin Details

Severity: High

ID: 57890

File Name: novell_iprint_578.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2012/02/10

Modified: 2012/08/30

Dependencies: 43060

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:novell:iprint

Required KB Items: SMB/Novell/iPrint/Version, SMB/Novell/iPrint/Version_UI

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/02/09

Vulnerability Publication Date: 2012/02/09

Reference Information

CVE: CVE-2011-4185, CVE-2011-4186, CVE-2011-4187

BID: 51926

OSVDB: 78953, 78954, 78955