PHP 5.3.9 'php_register_variable_ex()' Code Execution (banner check)

critical Nessus Plugin ID 57825
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by a code execution vulnerability.

Description

According to its banner, the version of PHP installed on the remote host is 5.3.9. This version reportedly is affected by a code execution vulnerability.

Specifically, the fix for the hash collision denial of service vulnerability (CVE-2011-4885) itself has introduced a remote code execution vulnerability in the function 'php_register_variable_ex()' in the file 'php_variables.c'. A new configuration variable, 'max_input_vars', was added as a part of the fix. If the number of input variables exceeds this value and the variable being processed is an array, code execution can occur.

Solution

Upgrade to PHP version 5.3.10 or later.

See Also

https://gist.github.com/pilate/1725489

http://www.php.net/ChangeLog-5.php#5.3.10

http://www.nessus.org/u?d1ee2de8

http://svn.php.net/viewvc?view=revision&revision=323007

Plugin Details

Severity: Critical

ID: 57825

File Name: php_5_3_10.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 2/3/2012

Updated: 1/19/2021

Dependencies: php_version.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 2/2/2012

Vulnerability Publication Date: 2/1/2012

Reference Information

CVE: CVE-2012-0830

BID: 51830