Debian DSA-2400-1 : iceweasel - several vulnerabilities

critical Nessus Plugin ID 57811
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in Iceweasel, a web browser based on Firefox. The included XULRunner library provides rendering services for several other applications included in Debian.

- CVE-2011-3670 Gregory Fleischer discovered that IPv6 URLs were incorrectly parsed, resulting in potential information disclosure.

- CVE-2012-0442 Jesse Ruderman and Bob Clary discovered memory corruption bugs, which may lead to the execution of arbitrary code.

- CVE-2012-0444 'regenrecht' discovered that missing input sanitising in the Ogg Vorbis parser may lead to the execution of arbitrary code.

- CVE-2012-0449 Nicolas Gregoire and Aki Helin discovered that missing input sanitising in XSLT processing may lead to the execution of arbitrary code.

Solution

Upgrade the iceweasel packages.

For the oldstable distribution (lenny), this problem has been fixed in version 1.9.0.19-13 of the xulrunner source package.

For the stable distribution (squeeze), this problem has been fixed in version 3.5.16-12.

See Also

https://security-tracker.debian.org/tracker/CVE-2011-3670

https://security-tracker.debian.org/tracker/CVE-2012-0442

https://security-tracker.debian.org/tracker/CVE-2012-0444

https://security-tracker.debian.org/tracker/CVE-2012-0449

https://packages.debian.org/source/squeeze/iceweasel

https://www.debian.org/security/2012/dsa-2400

Plugin Details

Severity: Critical

ID: 57811

File Name: debian_DSA-2400.nasl

Version: 1.12

Type: local

Agent: unix

Published: 2/3/2012

Updated: 1/11/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:iceweasel, cpe:/o:debian:debian_linux:5.0, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2/2/2012

Reference Information

CVE: CVE-2011-3670, CVE-2012-0442, CVE-2012-0444, CVE-2012-0449

BID: 51753, 51754, 51756, 51786

DSA: 2400