OpenSSL 1.0.0f DTLS Denial of Service

medium Nessus Plugin ID 57712
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host may be affected by a denial of service vulnerability.

Description

According to its banner, the remote web server is running OpenSSL version 1.0.0f. This version has a flaw in the fix for CVE-2011-4108 such that Datagram Transport Layer Security (DTLS) applications that use it are vulnerable to a denial of service attack.

Solution

Upgrade to OpenSSL 1.0.0g or later.

See Also

https://www.openssl.org/news/secadv/20120118.txt

https://www.openssl.org/news/changelog.html

Plugin Details

Severity: Medium

ID: 57712

File Name: openssl_1_0_0g.nasl

Version: 1.7

Type: remote

Family: Web Servers

Published: 1/27/2012

Updated: 11/15/2018

Dependencies: openssl_version.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Ease: No known exploits are available

Patch Publication Date: 1/18/2012

Vulnerability Publication Date: 1/18/2012

Reference Information

CVE: CVE-2012-0050

BID: 51563