OpenSSL 0.9.8s DTLS Denial of Service

Medium Nessus Plugin ID 57711

Synopsis

The remote host may be affected by a denial of service vulnerability.

Description

According to its banner, the remote web server uses OpenSSL version 0.9.8s. This version has a flaw in the fix for CVE-2011-4108 such that Datagram Transport Layer Security (DTLS) applications that use it are vulnerable to a denial of service attack.

Solution

Upgrade to OpenSSL 0.9.8t or later.

See Also

https://www.openssl.org/news/secadv/20120118.txt

https://www.openssl.org/news/changelog.html

Plugin Details

Severity: Medium

ID: 57711

File Name: openssl_0_9_8t.nasl

Version: 1.7

Type: remote

Family: Web Servers

Published: 2012/01/27

Updated: 2018/11/15

Dependencies: 57323

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/01/18

Vulnerability Publication Date: 2012/01/18

Reference Information

CVE: CVE-2012-0050

BID: 51563