IBM WebSphere MQ Client 6.x < 6.0.2.7 / 7.x < 7.0.1.0 CCDT Buffer Overflow

medium Nessus Plugin ID 57710
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host has a service installed that is affected by a privilege escalation vulnerability.

Description

The IBM WebSphere MQ client installed on the remote Windows host is version 6.x prior to 6.0.2.7 or version 7.x prior to 7.0.1.0. It is, therefore, affected by a heap-based buffer overflow flaw that allows a local attacker, using a specially crafted Client Channel Definition Table (CCDT) file, to gain unauthorized privileges.

Solution

Upgrade to WebSphere MQ Client 6.0.2.7 / 7.0.1.0 or later.

See Also

https://www-304.ibm.com/support/docview.wss?uid=swg27007069

Plugin Details

Severity: Medium

ID: 57710

File Name: websphere_mq_client_6027_7010.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 1/27/2012

Updated: 8/6/2018

Dependencies: websphere_mq_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: Medium

Base Score: 4.1

Temporal Score: 3

Vector: AV:L/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:websphere_mq

Required KB Items: installed_sw/IBM WebSphere MQ

Exploit Ease: No known exploits are available

Patch Publication Date: 7/8/2009

Vulnerability Publication Date: 6/5/2009

Reference Information

CVE: CVE-2009-0900

BID: 50460