IBM WebSphere MQ 6.x < 6.0.2.7 / 7.x < 7.0.1.0 Queue Manager Buffer Overflow RCE

critical Nessus Plugin ID 57709
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host has a service installed that is affected by a remote code execution vulnerability.

Description

The IBM WebSphere MQ server installed on the remote Windows host is version 6.x prior to 6.0.2.7 or version 7.x prior to 7.0.1.0. It is, therefore, affected by a buffer overflow flaw in the queue manager. A remote, unauthenticated attacker, by submitting a specially crafted request, can exploit this to execute arbitrary code in the context of the application.

Solution

Upgrade to WebSphere MQ 6.0.2.7 / 7.0.1.0 or later.

See Also

http://www-01.ibm.com/support/docview.wss?uid=swg21386826

Plugin Details

Severity: Critical

ID: 57709

File Name: websphere_mq_6027_7010.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 1/27/2012

Updated: 8/6/2018

Dependencies: websphere_mq_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:websphere_mq

Required KB Items: installed_sw/IBM WebSphere MQ

Exploit Ease: No known exploits are available

Patch Publication Date: 5/29/2009

Vulnerability Publication Date: 5/29/2009

Reference Information

CVE: CVE-2009-0896

BID: 35170

CWE: 119