Google Chrome < 16.0.912.77 Multiple Vulnerabilities

High Nessus Plugin ID 57666


The remote host contains a web browser that is affected by multiple vulnerabilities.


The version of Google Chrome installed on the remote host is earlier than 16.0.912.77 and is, therefore, affected the following vulnerabilities:

- Use-after-free errors exist related to DOM selections, DOM handling and Safe Browsing functionality.
(CVE-2011-3924, CVE-2011-3925, CVE-2011-3928)

- A heap-based buffer overflow exists in the 'tree builder'. (CVE-2011-3926)

- An error exists related to an uninitialized value in 'Skia'. (CVE-2011-3927)


Upgrade to Google Chrome 16.0.912.77 or later.

See Also

Plugin Details

Severity: High

ID: 57666

File Name: google_chrome_16_0_912_77.nasl

Version: $Revision: 1.8 $

Type: local

Agent: windows

Family: Windows

Published: 2012/01/24

Modified: 2016/05/16

Dependencies: 34196

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/01/23

Vulnerability Publication Date: 2012/01/23

Reference Information

CVE: CVE-2011-3924, CVE-2011-3925, CVE-2011-3926, CVE-2011-3927, CVE-2011-3928

BID: 51641, 52956

OSVDB: 78543, 78544, 78545, 78546, 78547