Apache 2.2.x < 2.2.13 APR apr_palloc Heap Overflow

critical Nessus Plugin ID 57603
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server is affected by a buffer overflow vulnerability.


According to its self-reported banner, the version of Apache 2.2.x running on the remote host is prior to 2.2.13. As such, it includes a bundled version of the Apache Portable Runtime (APR) library that contains a flaw in 'apr_palloc()' that could cause a heap overflow.

Note that the Apache HTTP server itself does not pass unsanitized, user-provided sizes to this function so it could only be triggered through some other application that uses it in a vulnerable way.


Upgrade to Apache 2.2.13 or later.

See Also


Plugin Details

Severity: Critical

ID: 57603

File Name: apache_2_2_13.nasl

Version: 1.7

Type: remote

Family: Web Servers

Published: 1/19/2012

Updated: 6/29/2018

Dependencies: apache_http_version.nasl

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Ease: No known exploits are available

Patch Publication Date: 8/9/2009

Vulnerability Publication Date: 8/4/2009

Reference Information

CVE: CVE-2009-2412

BID: 35949

CWE: 189