Mandriva Linux Security Advisory : libxml2 (MDVSA-2012:005)

High Nessus Plugin ID 57567


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been found and corrected in libxml2 :

A heap-based buffer overflow in libxml2 allows remote attackers to cause a denial of service or possibly have unspecified other impact via unknown vectors (CVE-2011-3919).

The updated packages have been patched to correct this issue.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 57567

File Name: mandriva_MDVSA-2012-005.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2012/01/17

Modified: 2016/03/11

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64xml2-devel, p-cpe:/a:mandriva:linux:lib64xml2_2, p-cpe:/a:mandriva:linux:libxml2-devel, p-cpe:/a:mandriva:linux:libxml2-python, p-cpe:/a:mandriva:linux:libxml2-utils, p-cpe:/a:mandriva:linux:libxml2_2, cpe:/o:mandriva:linux:2010.1, cpe:/o:mandriva:linux:2011

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/01/16

Reference Information

CVE: CVE-2011-3919

BID: 51300

OSVDB: 78148

MDVSA: 2012:005